using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(.*?)\h*.*>.+<\/\1>(*SKIP)(*FAIL)|(<|>)";
string input = @"b<a=2<sup>2</sup>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}