// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[\w\d]*?":{"[\w]*?":?\{"[\w]*?":[0-9\d]*,"[\w]*?":[0-9\d]*,"[\w]*?":[0-9\d]*},"[\w]*\":{"[\w]*\":[0-9\d]*,"[\w]*\":[0-9\d]*,"[\w]*\":[0-9\d]*,"[\w]*\":[0-9\d]*}}"#).unwrap();
let string = "2020-11-04 17:14:29,367 : [INFO ] GW-26-C-1 [c.n.s.s.MyKafkaConsumer:19] [GW-26-C-1] : ConsumerRecord(topic = CBBL_GP, partition = 2, leaderEpoch = 20, offset = 4386, CreateTime = 1604488454631, serialized key size = -1, serialized value size = 1139, headers = RecordHeaders(headers = [], isReadOnly = false), key = null, value = {\"clientUserName\":\"usersms@communitybank.com.bd\",\"test\":false,\"clientCbsSmsId\":\"20201104_051123_S179371_22\",\"txnDateTime\":{\"date\":{\"year\":2020,\"month\":11,\"day\":4},\"time\":{\"hour\":17,\"minute\":7,\"second\":22,\"nano\":0}},\"senderId\":\"COMMUNITY_BANK\",\"acctId\":\"0010112519201\",\"creditDebit\":\"C\",\"amount\":30886,\"cellPhone\":\"8801735654457\",\"sendToNumber\":\"8801735654457\",\"message\":\"Community Bank - Your account 001*******201 has been credited with BDT 30886 (SALARY OCTOBER-2020) on 04-Nov-20 05:14:23 PM BST. Your Current Balance is BDT 32057.38. Thank you.\",\"clientRequestDateTime\":{\"date\":{\"year\":2020,\"month\":11,\"day\":4},\"time\":{\"hour\":17,\"minute\":14,\"second\":14,\"nano\":631000000}},\"expiryDateTime\":{\"date\":{\"year\":2020,\"month\":11,\"day\":5},\"time\":{\"hour\":5,\"minute\":14,\"second\":23,\"nano\":0}},\"retryCount\":1,\"valid\":true,\"validateCell\":false,\"defaultSmsLength\":160,\"exceedDefaultSmsLength\":false,\"telcoLocalPrefix\":\"017\",\"telcoName\":\"GP\",\"status\":\"GW_PENDING\",\"isDirty\":false,\"customerNo\":\"0112519\",\"smsFormat\":\"SMS_FORMAT_DEFAULT\",\"unicode\":0,\"includeResend\":false,\"messagetype\":0,\"smsResultList\":[],\"version\":0,\"active\":1,\"tzName\":\"Asia/Dhaka\"})";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}