import re
regex = re.compile(r"(\d{3})(\d{3})(\d{3})(\d{2})")
test_str = "12345678912"
subst = "$1.$2.$3-$4"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)