using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^:]*):\/\/([^:@]*):?([^@]*)@?([^\/:]*):?([0-9]*)\/([^\?]*)\??(.*)";
string input = @"redis://redis-analytics-airflow.signal:6379/1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}