package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+\.\d+)$`)
var str = `These
111.111
Not these
111..110....11
11.11.11.11`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}