const regex = new RegExp('(((gain|loss|^d).*)isposal.*associates?)|', 'gmi')
const str = `CFA
Disposal of an associates
Gain on disposal of an associate
Gain/loss on disposal of an associate
loss on disposal of an associate
CFI
Proceeds from disposal of an associate
abc`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}