$re = '/^(?!\d*(\d)\d*\1)\d{3}\*\d+$/m';
$str = '123*5000
223*443
908*22
34*5000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);