package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"ErrorCode"\:\s+(\d+)`)
var str = `"ErrorCode": 37`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}