$re = '/(?:<html|(?<!^)\G)\h*(?:([^=\n\h]+)=([\'"])((?:\\\\\2|(?!\2).)*)\2)?/mi';
$str = '<html>
<html lang="en">
<html class="my-class">
<html class="my-class" lang="en">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);