#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\(\s*([0-9]+)\)\[([a-zA-Z0-9\s*:]*)\|\s*([0-9]{1,5}\:[0-9]{3})\s*(?:\[([0-9]{1,3})\:[0-9]{1,3}\])?\]\{([0-9]{1,4})\}([a-zA-Z0-9]+)\@([a-zA-Z0-9]+)\:(.+)\((?:.+)\)([\$|#])\s{1}(.+)(\n(.+))+"
Local $sString = "( 6)[Thu Sep 01 04:47:12| 2:000]{1}jhyland@jhmac:~(✓)$ ls" & @CRLF & _
"Applications kn Public bash_profile.orig pdfdata.json search_src-printr.txt vim-colorschemes" & @CRLF & _
"BaseServer.py LDEV-342302 VirtualBox VMs file.py pipe1 search_src.json vim-config" & @CRLF & _
"Desktop Library _includexmlrpc.php filename.txt profile-configs test.php vimrc.disabled" & @CRLF & _
"Documents Movies _includexmlrpc.php.original gvimrc.disabled profile-configs-orig test.txt" & @CRLF & _
"Downloads Music _includexmlrpc.php.original2 index.php protected_backup.tar.gz tester" & @CRLF & _
"Google Drive Pictures as.txt items.php.orig search-stuff.js tmp" & @CRLF & _
"InventoryServer.py ProblemServer.py.new-working bash_profile new.bash_profile search_src-20.json tmp.txt" & @CRLF & _
"( 6)[Thu Sep 01 04:47:13| 0:000]{2}jhyland@jhmac:~(✓)$ cd /tmp" & @CRLF & _
"( 6)[Thu Sep 01 04:47:18| 0:000]{3}jhyland@jhmac:/tmp(✓)$ ls | wc -l" & @CRLF & _
" 15" & @CRLF & _
"( 6)[Thu Sep 01 04:47:22| 0:000]{4}jhyland@jhmac:/tmp(✓)$ sudo su -" & @CRLF & _
"( 6)[Thu Sep 01 04:47:25| 0:000]{1}root@jhmac:~(✓)# whoami" & @CRLF & _
"root" & @CRLF & _
"( 6)[Thu Sep 01 04:47:28| 0:000]{2}root@jhmac:~(✓)# history | tail -n 2" & @CRLF & _
" 393 whoami" & @CRLF & _
" 394 history | tail -n 2" & @CRLF & _
"( 6)[Thu Sep 01 04:47:39| 0:000]{3}root@jhmac:~(✓)#" & @CRLF & _
"( 6)[Thu Sep 01 04:47:40| 0:000]{3}root@jhmac:~(✓)# fail" & @CRLF & _
"-sh: fail: command not found" & @CRLF & _
"( 6)[Thu Sep 01 04:47:44| 0:000]{4}root@jhmac:~(127)#" & @CRLF & _
"( 6)[Thu Sep 01 04:47:44| 0:000]{4}root@jhmac:~(127)#" & @CRLF & _
"( 6)[Thu Sep 01 04:47:44| 0:000]{4}root@jhmac:~(127)# true" & @CRLF & _
"( 6)[Thu Sep 01 04:47:46| 0:000]{5}root@jhmac:~(✓)#" & @CRLF & _
"( 6)[Thu Sep 01 04:50:35| 0:000]{1}root@jhmac:~(✓)# exit" & @CRLF & _
"logout" & @CRLF & _
"( 6)[Thu Sep 01 04:50:07| 0:000]{8}jhyland@jhmac:~(✓)$ ls -1 | head" & @CRLF & _
"Applications" & @CRLF & _
"BaseServer.py" & @CRLF & _
"Desktop" & @CRLF & _
"Documents" & @CRLF & _
"Downloads" & @CRLF & _
"Google Drive" & @CRLF & _
"InventoryServer.py" & @CRLF & _
"LDEV-342302" & @CRLF & _
"Library" & @CRLF & _
"Movies"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")