re = /(?!.*\n\n)\[Chorus.*?\].*?$/
str = '[Chorus: x2]
Some Lyrics
Some More Lyrics
[Verse]
Lyrics
Lyrics
Lyrics
[Chorus]
Some Lyrics
Other Lyrics'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end