$re = '/\d{3,}/';
$str = '1
11
111
1111
11111
111111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);