#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z\u00C0-\u024F\u1E00-\u1EFF]"
Local $sString = "Ràhūl" & @CRLF & _
"Vērmá" & @CRLF & _
"Âsmítä" & @CRLF & _
"Vêrmã" & @CRLF & _
"Süshîlå" & @CRLF & _
"Vërmā" & @CRLF & _
"Prèmchænd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")