# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"(?x)(\n"
r"# phone number\n"
r"(\+1)?\n"
r"(\s)?\n"
r"(\(\d\d\d\))? #area code optional\n"
r"(\s|-) # first separator\n"
r"\d\d\d # first 3 digits\n"
r"- # Separator\n"
r"\d\d\d\d # last 4 digits\n"
r")")
test_str = ("+1 (786) 665-5397\n"
"+1 (786) 773-7145\n"
"+1 (786) 804-8869\n"
"+1 (786) 806-5097\n"
"+1 (786) 856-7950\n"
"+1 (786) 862-2875\n"
"+1 (786) 915-7830\n"
"+1 (786) 991-4304\n"
"+1 (857) 334-1162\n"
"+1 (862) 944-0090\n"
"+1 (863) 307-5291\n"
"+1 (914) 826-4343\n"
"+1 (918) 992-1382\n"
"+1 (954) 226-7037")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.