re = /(<CreditApplication ID=\x222222222\x22>)(\s+\S+.*\s+)+(<\/CreditApplication>)/m
str = '<CreditApplication ID="1111111">
<CreditApplicationDetails>
<DecisionID>11223366</DecisionID>
<LenderReference>256548</LenderReference>
</CreditApplicationDetails>
<CreditApplicationHistoryLogs>
<Log ID="25486522">
<Status>FULFILLED</Status>
<Timestamp>2018-06-02T11:52:05+01:00</Timestamp>
</Log>
</CreditApplicationHistoryLogs>
<ConsumerDetails>
<Title>Mr</Title>
<FirstName>ROXY</FirstName>
</ConsumerDetails>
<Decision ID="2255222">
<PolicyName>Credit Strategy V20</PolicyName>
<DecisionStatus>ACCEPT</DecisionStatus>
<Timestamp>2018-06-02T11:38:36+01:00</Timestamp>
<Rule>
<RuleNumber>1</RuleNumber>
<RuleName>Applicant over 18 years old</RuleName>
</Rule>
<Rule>
<RuleNumber>140</RuleNumber>
<RuleName>Notice of correction found</RuleName>
</Rule>
</Decision>
<CreditSentryData>
<MobileStatus>1</MobileStatus>
</CreditSentryData>
</CreditApplication>
<CreditApplication ID="2222222">
<CreditApplicationDetails>
<DecisionID>25252525</DecisionID>
<LenderReference>3636365</LenderReference>
</CreditApplicationDetails>
<CreditApplicationHistoryLogs>
<Log ID="454545">
<Status>FULFILLED</Status>
<Timestamp>2018-06-02T11:52:05+01:00</Timestamp>
</Log>
</CreditApplicationHistoryLogs>
<ConsumerDetails>
<Title>Mr</Title>
<FirstName>AMIT</FirstName>
</ConsumerDetails>
<Decision ID="112255874">
<PolicyName>Credit Strategy V20</PolicyName>
<DecisionStatus>ACCEPT</DecisionStatus>
<Timestamp>2018-06-02T11:38:36+01:00</Timestamp>
<Rule>
<RuleNumber>1</RuleNumber>
<RuleName>Applicant over 18 years old</RuleName>
</Rule>
<Rule>
<RuleNumber>140</RuleNumber>
<RuleName>Notice of correction found</RuleName>
</Rule>
</Decision>
<CreditSentryData>
<MobileStatus>1</MobileStatus>
</CreditSentryData>
</CreditApplication>
<CreditApplication ID="33665588">
<CreditApplicationDetails>
<DecisionID>558454</DecisionID>
<LenderReference>669855</LenderReference>
</CreditApplicationDetails>
<CreditApplicationHistoryLogs>
<Log ID="254112">
<Status>FULFILLED</Status>
<Timestamp>2018-06-02T11:52:05+01:00</Timestamp>
</Log>
</CreditApplicationHistoryLogs>
<ConsumerDetails>
<Title>Mr</Title>
<FirstName>KATY</FirstName>
</ConsumerDetails>
<Decision ID="254125">
<PolicyName>Credit Strategy V20</PolicyName>
<DecisionStatus>ACCEPT</DecisionStatus>
<Timestamp>2018-06-02T11:38:36+01:00</Timestamp>
<Rule>
<RuleNumber>1</RuleNumber>
<RuleName>Applicant over 18 years old</RuleName>
</Rule>
<Rule>
<RuleNumber>140</RuleNumber>
<RuleName>Notice of correction found</RuleName>
</Rule>
</Decision>
<CreditSentryData>
<MobileStatus>1</MobileStatus>
</CreditSentryData>
</CreditApplication>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result