$re = '/_(\d)/';
$str = 'ABC01-001-M-001_0.dwg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);