package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]+)(\s+метров|м)`)
var str = `10 метров`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}