re = /(?<=<br><i>)[^<\/i>].*(?=<\/i><br>)/i
str = '<br><i>d2dded</i><br><br><i>d2dded</i><br>
<br><i>"Não pisoteie quando subir as escadas - sua irmã está dormindo."</i><br>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end