$re = '/^([a-z]+)(\s)?([a-z]*)/i';
$str = 'Josh Garnick';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);