re = /^([a-z0-9_\.-]+\@[\da-z\.-]+\.[a-z\.]{2,6})$/m
str = 'ktrichas@gmail.com
papaki_papa@test-asd.sadf.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end