const regex = new RegExp('\\]\\s*(AN|AV)\\s*1\\s*([\\w\\s]+?)\\s*2\\s*([\\w\\s]+?)\\s*3\\s*((?:(?!cui).)*)', 'gm')
const str = `campo] AN 1 campo 2 prato con penna B sps a 1 3 campo con penna C as a 1 cfr Nota filologica
campo] AN 1 campo 2 prato con penna B sps a 1 3 da cui con penna C as a 1 cfr Nota filologica
That should match
] AN 1 words 2 words 3 words
or
] AV 1 words 2 words 3 words`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}