import re
regex = re.compile(r"(^\w+ &.*)", flags=re.MULTILINE)
test_str = ("Paul & Mary Atkins - \n"
"John Arnold & Dave Badman - \n"
"----DO NOT MATCH----\n"
"John Baines & Dave Adams - \n"
" ")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)