// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([ .\w']+?)($|mp3|[s|S]\d{1,}|\(.*\)|[A-Z]{2,}|\W\d{4}\W?.*)").unwrap();
let string = "Better Call Saul S02E03 - Amarillo.mkv
dexter.New.Blood.mp3.S01E03.mkv
Rick.and.Morty.S05E01.720p.AMZN.WEBRip.x264-GalaxyTV.mkv
Black.Widow.mp4
Dexter.New.Blood.S01E01.mp4
Radin (2016) VFF [1080p] BluRay x264-PopHD.mkv
This Is the End 1080p MULTI 2013 BluRay x264.mkv
[ www.CpasBien.cm ] Marseille.2016.FRENCH.DVDRip.XviD-UTT.avi
(Complet)Le Pere Noel Est Une Ordure (Divx-Francais).avi
20.Ans.d.Ecart.2013.FRENCH.BRRIP.XviD-FUZION.avi
Blade.Runner.2049.2017.VOSTFR.FANSUB.1080p.WEB-DL.H264.AC3-TRUEDUKES.WwW.Torrent9.pe";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}