$re = '/\bSet(?!\(Value\))(?:\s+Value)?\b/m';
$str = 'Set
Set Value
Set(Value)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);