$re = '/^([a|i|r]):(?(?<=i:)(\d+)|()):(\d+)$/m';
$str = 'a::12
i:999:12
i::2
r::4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);