import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?:<\\?xml[^>]+>)?\\s*<([^>]+?)>[\\s\\S]+?<\\/\\1>\\s*?$";
final String string = "<?xml version=\"1.0\" encoding=\"UTF-8\"?>\n"
+ "<Recordings>\n"
+ " <Recording OVSTag=\"R00259003F89415063015030509\" Name=\"test\">\n"
+ " <Channel EndTC=\"15:03:59:10\" BeginTC=\"15:03:05:22\" Index=\"3\"/>\n"
+ " <Clip UName=\"801\" OVSTag=\"C00259003F89415063015394226\" Name=\"test_sub_1\">\n"
+ " <Channel OutPoint=\"15:03:20:19\" InPoint=\"15:03:05:22\" Default=\"true\" Index=\"3\"/>\n"
+ " <SmartEvent ID=\"b703578e-8dd1-6b72-c8c7-237132f66652\"/>\n"
+ " <SmartEvent ID=\"9287112f-45a6-1f43-0c28-76111b1b710f\"/>\n"
+ " <SmartEvent ID=\"a71c9fff-d1ae-7f89-5f1a-7a0a281f9904\"/>\n"
+ " </Clip>\n"
+ " </Recording>\n"
+ "</Recordings>\n"
+ "<SmartEvents>\n"
+ " <SmartEvent PageID=\"f3e9e264-3f1a-0f15-814a-cc7c535c1251\" ID=\"b703578e-8dd1-6b72-c8c7-237132f66652\" Name=\"FOUL\"/>\n"
+ " <SmartEvent PageID=\"bc3e8a3b-ea74-dad2-bd55-49a7d9725b83\" ID=\"9287112f-45a6-1f43-0c28-76111b1b710f\" Name=\"MESSI\"/>\n"
+ " <SmartEvent PageID=\"d15ed885-b68b-69db-8d76-3dc21e47d1d1\" ID=\"a71c9fff-d1ae-7f89-5f1a-7a0a281f9904\" Name=\"RAMOS\"/>\n"
+ "</SmartEvents>\n"
+ "<SmartEventPages>\n"
+ " <SmartEventPage ID=\"d15ed885-b68b-69db-8d76-3dc21e47d1d1\" Name=\"Real Team\"/>\n"
+ " <SmartEventPage ID=\"f3e9e264-3f1a-0f15-814a-cc7c535c1251\" Name=\"Action\"/>\n"
+ " <SmartEventPage ID=\"bc3e8a3b-ea74-dad2-bd55-49a7d9725b83\" Name=\"Barcelona Team\"/>\n"
+ "</SmartEventPages>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}