$re = '/^Set-Cookie:\s*([^;\r\n]*)/mi';
$str = 'HTTP/1.1 200 OK
Content-Length: 27
Content-Type: application/json; charset=utf-8
Server: Microsoft-IIS/7.5
Access-Control-Allow-Origin: http://localhost
Set-Cookie: sessionToken=22A2...DB87
X-Powered-By: ASP.NET
Date: Tue, 16 Feb 2016 16:28:12 GMT';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);