# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:\s{4})*\s{1,3}\S"
test_str = ("import math\n\n\n"
"def f(): # previous two line are empty (0 space), should NOT be matched\n"
" \n"
" a = 1 # previous line is indented by 4 spaces, should NOT be matched\n"
" \n"
" if a==1: # previous line is indented by 3 spaces, SHOULD be matched\n"
" \n"
" b = a # previous line is indented by 8 spaces, should NOT be matched")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.