$re = '/(?!^-)[+*\/-](\s?-)?/';
$str = '-5.0 + 9.34 - 6.0 * -2.1 * 3.1 / -2.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);