re = /(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)_*(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)_*){3}/m
str = '192__.168__.88__.1__'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end