$re = '/(?:w+])*+(?<li>[\s\S]*?[;.\n])/m';
$str = 'ELECTRICAL PRODUCTS
asdasd
asd
asd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);