using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"CL\d+__\K(?:(?!__).)+(?=__)";
string input = @"20260317_104524__CL2418942__SOC_PM_DF_CSTATE_REGR__df_cstate_regr__df_umc_nbio_hubs_pcie_msub_\_.xml
... and I wa";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}