#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!$)(?:[^\n)(]*\([^()]+\))*[^)(]*$"
Local $sString = "aaaaaa" & @CRLF & _
"(asdasd)" & @CRLF & _
"aaaa(bbb)a" & @CRLF & _
"(aaa)aaaa" & @CRLF & _
"aaaaaa(aaaa)" & @CRLF & _
"aaaa(bbb)(ccc)ddd" & @CRLF & _
"aaaa(bbbb)cccc(dddd)eeee" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
")aaaa" & @CRLF & _
")aaaa(asd)" & @CRLF & _
"aaaaaa(" & @CRLF & _
"aaaa(bbb))" & @CRLF & _
"aaa(bbb" & @CRLF & _
"aaaaa((bbbb)cccc" & @CRLF & _
"aaaa(bbbb))ccc" & @CRLF & _
"aaaa(aasd(adssad))ad" & @CRLF & _
"adassd(aas(add)adsa(asda)ad)" & @CRLF & _
"()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")