re = /^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[@$!%*?&])[A-Za-z\d@$!%*?&]{8,64}$/
str = 'asdfjkl;123?U'
# Print the match result
str.match(re) do |match|
puts match.to_s
end