re = /(?P<day>\d\d).(?P<month>\d\d).(?P<year>\d{4})_/
str = '28.09.2017_SD1_to_orcam_bills_10indian'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end