package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)((?:\S+\s+){0,3})\bRAM\b\s*((?:\S+\s+){0,3})`)
var str = `Nokia Lumia 930 Smartphone, Display 5 pollici, Fotocamera 20 MP, 2GB RAM, Processore Quad-Core 2,2GHz, Memoria 32GB, Windows Phone 8.1, Bianco [Germania]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}