$re = '/\$\d+/';
$str = 'jone has done $15 per unit: "good luck"';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);