package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+) days`)
var str = `365 days
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}