import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*?)\\bdefault\\b";
final String string = "../app/code/community/Company/Module/Block/Adminhtml/Location/Grid.php\n"
+ "../app/code/community/Company/Module/Block/Adminhtml/Location/Import.php\n"
+ "../app/code/community/Company/Module/Block/Adminhtml/Location/Edit/Form.php\n"
+ "../app/code/community/Company/Module/Block/Adminhtml/Location/Edit/Import.php\n"
+ "../app/code/community/Company/Module/Block/Adminhtml/Location/Edit/Tabs.php\n"
+ "../app/code/community/Company/Module/Block/Adminhtml/Location/Edit/Tab/Form.php\n"
+ "../app/code/community/Company/Module/Block/Adminhtml/Location/Edit/Tab/Import.php\n"
+ "../app/code/community/Company/Module/controllers/IndexController.php\n"
+ "../app/code/community/Company/Module/controllers/LocationController.php\n"
+ "../app/design/adminhtml/default/default/layout/pmodule.xml\n"
+ "../app/design/frontend/default/default/layout/pmodule.xml\n"
+ "../app/design/frontend/default/default/template/company/module/gmap.phtml";
final String subst = "\\1rwd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}