package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([$£€¥₹])?(\d{1,3}(?:[, ]?\d{1,3})?(?:.\d+)?)(?(1)|(kr\.?|Kč))`)
var str = `The cost of this car with a 3.5 litre engine, is €2,927.100, or $3 271.32. In Sweden that would be around 27000kr. I would have to work overtime for 215 days to save the money for that, even though my job in the Czech Republic pays 436.5Kč an hour, and I can save 10% percent of that. My buddy in Japan, bought one for ¥357014.83`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}