import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Rs.|[$£€¥₹])?\\s*(\\d{1,3}(?:[, ]?\\d{1,3})?(?:.\\d+)?)(?(1)|\\s*(kr\\.?|Kč|INR|€))";
final String string = "The cost of this car with a 3.5 litre engine, is €2,927.100, or $3 271.32. In Sweden that would be around 27000kr. I would have to work overtime for 215 days to save the money for that, even though my job in the Czech Republic pays 436.5Kč an hour, and I can save 10% percent of that. My buddy in Japan, bought one for ¥357014.83\n\n"
+ "Rs. 2000 , Rs.2000 , Rs 20,000.00 ,20,000 INR 200.25 INR\n\n"
+ "It was just pointed out to me that in France, amounts are written with the Euro-sign post-fixed, like 2 927,10€ or 2 927.10€ or 2927,10€ or 2927.10€.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}