re = /pps=\[?([^;]+)/
str = 'http://www.abcexample.com/landpage/?pps=[Y/lyPw==;id_1][Y/lyP2ZZYxi==;id_2];[5403;ord];
http://www.abcexample.com/landpage/?pps=Y/lyPw==;id_1;unknown;ord;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end