re = /^([0-9]{2})([0-9]{4})([0-9]{4})([0-9]{4})([0-9]{4})([0-9]{4})([0-9]{2})$/
str = '000000000000000000000000'
# Print the match result
str.match(re) do |match|
puts match.to_s
end