$re = '/0[1-9]+0*$/m';
$str = '10001
=> 01
2010
=> 010
10013
=> 013';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);