re = /m=(\w+)/
str = '2016-03-08 11:23:25 test_data:0317: m=string_I_want max_count: 17655, avg_size: 320, avg_rate: 165'
# Print the match result
str.match(re) do |match|
puts match.to_s
end