$re = '/\[((?:[^\[\]]+|(?R))+)\]/';
$str = '[if:name <strong>[name]</strong>]
<a href="http://www.example.com/place/[id]/">For more info...</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);