$re = '/^((\w{2}\.){2})\w{2}\.(.*)$/';
$str = 'aa.bb.cc.dd.ee.xx';
$subst = "\1NN.\3";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;