# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=From:)((?:(?!>).)*)>"
test_str = ("From: FirstName LastName <FirstName.MiddleName.LastName@someemail.com>\n"
" In-Reply-To: <fc7b93ca4dab.531f4e68@my.bcit.ca>\n"
" ------------------------------------------------- \n"
" From: \"FirstName. MiddleName =?iso-8859-1?b?TWFydO1uZXo=?= LastName\"\n"
" <somemeail@something.otherthing.es> \n"
" Subject: Re: Some Randome Data \n"
" In-Reply-To: <42043F8EC804DB48A3C4AF477195328F272CB9@exchange.something.local>\n"
" ------------------------------------------------- \n"
" From: \"FirstName MiddleName LastName\" <LastName@someemail.com>\n"
" Subject: Some Randome Subject \n"
" -------------------------------------------------\n"
" From: \"FirstName. MiddleName =?iso-8859-1?b?TWFydO1uZXo=?= LastName\"\n"
" <somemeail@something.otherthing.es\n"
" > \n"
" Subject: Re: Some Randome Data \n"
" In-Reply-To: <42043F8EC804DB48A3C4AF477195328F272CB9@exchange.something.local>\n"
" ------------------------------------------------- \n"
" From: \"FirstName. MiddleName =?iso-8859-1?b?TWFydO1uZXo=?= LastName\"\n"
" <\n"
" somemeail@something.otherthing.es\n"
" > \n"
" Subject: Re: Some Randome Data \n"
" In-Reply-To: <42043F8EC804DB48A3C4AF477195328F272CB9@exchange.something.local>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.