$re = '/Dim (...+).*/';
$str = 'Dim m_objExaminationRegion, asdfa, asdf
asfd
asfd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);