package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\S\r\n]+`)
var str = `test-default-space
test01-default-space`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}